WP中国本土化社区(WP-China.org),立志于建设国内的WordPress生态基础设施以求内化WordPress,使之更契合中国人的使用习惯。

之所以要做这一块的工作是因为wordpress.org网络慢、参与门槛高、机制不适宜国内大环境以及社区中充斥着台独、美左份子对大陆华人的排斥。

截至2020年8月12日,简体中文用户只占全部WordPress用户的2.1%,不能指望得到wordpress.org足够的重视,就好像之前一个429问题就持续了半年之久一样。

正是基于上述这些原因,所以我希望能建立一个由中国人主导的社区生态,采用一些激进的以及贴近国情的措施来刺激生态繁荣,例如:引入AI负担主要的翻译工作;应用市场允许上架闭源、付费应用等等众多改革措施。

我承认这个想法是有些疯狂的,推进过程中会面临来自诸多方面的诸多困难,无论是技术还是宣传还是方案制定还是社区组织都存在很多困难。

不过,好在我是个纯粹的理想主义者,我并不指望这个项目能盈利,更多的是期待着通过这样一个项目进行学习与积累。或者说,其实我是把这当作一个好玩儿的模拟经营类游戏来推进的。

目前的成果

1、对官方应用市场、Gravatar头像、谷歌字体等资源进行了国内的反代加速

2、本土翻译平台(https://translate.wp-china.org)已上线,该平台对标WordPress官方翻译平台(https://translate.wordpress.org),配合WP-China-Yes插件,可以提供与官方翻译平台一致的自动化体验, 主要改进在于首次采用AI作为首要翻译手段,之所以能这样干是因为我基于Google翻译开发了针对中文i18n翻译的预处理及后期处理算法,最终的翻译效果应该说是吊打PoEdit Pro软件带的机翻——无需人工二次处理即符合i18n规范,可以被WordPress直接读取。

目前主要的困难是对于词汇、短语这些因为没有上下文语境,经常会被翻译错误,这些需要人工参与校准。也欢迎你参与到翻译校准的工作^_^

另外受限于服务器资源,我暂时无法实现对整个官方仓库进行监听与翻译,目前只是国内有人使用的包才会被本土翻译平台所监听,对于新安装的包则不超过24小时就会被监听到。

3、除了对官方应用市场反代外,我还开发了一个本土版本的应用市场,该应用市场目前与官方的主要区别就是与本土翻译平台进行了整合,可以无缝为大家推送来自本土翻译平台的翻译包。

WP-China-Yes插件

因为无法直接修改cn.wordpress.org所分发的简体中文包,所以我开发了WP-China-Yes插件用来帮助大家将自己的WordPress切换到本土生态。

无需担心这会增加你的服务器负担,插件的安装包我会一直维持在几KB大小。

下载WP-China-Yes

自2020年4月15日起,已无法通过官方应用市场安装WP-China-Yes插件,详情见:公告

如需传播请直接复制此处的下载链接,该链接始终指向最新版

v3.2.0 特性

  1. 极致编码,安装包仅仅3KB大小,对服务器无任何负担
  2. 为官方应用市场提供反代加速,解决应用安装/更新缓慢、失败等问题
  3. 通过加速API调用和接管WordPress核心所依赖的静态文件来极大的加快站点后台访问速度
  4. 对接本土翻译平台,自动从本土翻译平台接收应用市场中所有作品的全量汉化支持(技术试验)
  5. 提供对Gravatar头像的加速支持
  6. 提供对谷歌字体的加速支持
  7. 提供对谷歌前端公共库的加速支持

加QQ群交流

如果你也想参与这场好玩儿的游戏——发表你的idea或是实际进行一些工作,又或是仅仅想关注项目发展动态,都请加QQ群:1046115671。目前主要的交流是在QQ群中进行的,社区论坛主要是用于进行一些需要持久化存储的讨论。

2021年3月8日更

这个项目还在持续发展,目前在开发新平台并筹备一个本土WordPress发行版,新平台开发站:wp-china-yes.com(稍微再强调一下:这个是开发站,所以请不要宣传~),新平台囊括了用户社区、应用市场、翻译平台、文档平台,基本实现了一个最基本的wordpress.org功能复刻,足以保障基于此的本土发行版正常工作。

 另外,老实说这个本土发行版的名字我想的相当的头疼,如果你有好的IDEA欢迎告诉我^_^

墨涩网推广者

像其他开源项目一样,本土化社区也需要有足够的知名度才能健康的发展,如果你也希望在宣传上出把力,请写一篇文章介绍本土化社区正在做的事情,或是介绍WP-China-Yes插件。当你发表了一篇推广文章后请来此页面留言,我也会将你的网站加入到下方的名单中,目前这已经汇集成了一个蜘蛛池,相信对你网站的SEO也大有脾益。

WordPress大学 | WordPress外贸建站专家 | Wr资源 | 知更鸟 | 青衫慧博客 | 长野的博客 | 奶爸建站笔记 | 虫子君 | 呆憨Blog | 留连暗香 | 臾离博客 | 魏艾斯笔记 | 设计窝 | 智诚云集 | 自学控 | 随时准备避雷 | boke112联盟 | 站长帮 | 王商博客 | 格子随笔 | 雪猫游戏攻略网 | 庞展博客 | 最省事 | 习休时期 | 云期刊 |自然 | 诗梦 | DengJia`s blog | ThemeBest | 未完待续 | 耗子博客 | 无忧SEO博客 | 瑞尔思 | 山大王 | 无名 | 生活的左上角 | 技术宅小明 | 七月博客 | 王思伟的博客 | 无主题博客 | 艾码汇 | 落樱网络 | 笔点未来先生 | 叽咕资源网 | 源码分享网 | 新席地网博客 | WP中文网 | 搜刮好东西 | 意更博客 | 青衣楼 | 里维斯社 | 泪雪博客 | 云服务器排行榜 | 无名小站 | 夜雨聆风 | MyWa我娃  | Ryanjie 博客 | 汐岑小窝 | Yremp | WPMES | WM云建站 | SEO视频 | 栖枝Perch | HAM小站 | 米随随 | 技术松鼠 | 晨风笔记 | ZDMZ | enterdawn | 瀚域博客 | MANZIER | 山野莽夫 | 零度猫 | 小兽WP | 沃茨博客 | WordPress主题之家 | 我是菜鸟 | 云轩阁 | 天边鱼Blog | 艺创源码屋 | 小T博客 | 主题客 | Call Me Bill | V民之家 | WordPress百宝箱 | 筱某佳 | 白天博客 | Npcink | 我有乐趣 | 宅到没朋友 | ytkah | 一号资源 | 怡文菌 | 晓梦 Blog | WPorder | DuKe Yin | 风雨轩窗日暮光 | 虾皮路 | 刘晟含的个人网站 | 莲梦青语 | 王会博客 | NAZ.CN | 蓝色创想 | 乔零 | WPBOM | 龙萱坤诺 | 何昌全博客 | wpFAQ | 魔源吧 | 我爱虚拟网 | GO破解 | 主机优惠券 | 励志语录网 | 老王博客 | flyzy小站 | 胡不过 | 奕星球 | 墨攻博客 | IDC严选 | 运维社区 | Govzzp的生活 | 豫章小站 | 恩月阁 | 大川渝读者 | 买对的 | Mannaze.COM | 百汇资源网 | 日暮星辰 | 腾龙工作室 | MIKELIN小蓝家 | WordPress迷 | 八点半博客 | 御宅说 | 搜外科技 | 薄荷先生 | 东方蓝 | 编程小站 | 科技Hub | 暮城博客 | a76yyyy个人技术站 | 晨夕阁 | 心语家园 | 红尘客网 | 六速博客 | 积微成著 | 幂彀社区 | 小苏的小窝 | 语幕 | 随意之光 | 牛魔博客 | 十星侦探网 | 等风起 | 木屋人 | Jeyfang的博客 | 承林私塾自学网 | 弄事堂 | LOYSEO | WP福利社云典网 | 一点优化 | 小酒资源吧 | 米饭科技 | 主题君 | 十星评测 | Charles的小星球 | 沙唐桔 | 爱特蜂土石方工程业务管理系统官网 | 一个微科技小破站 | 清风揽月阁 | SK导航网 | 遇见台儿庄 | 搬主题 | 落伍老站长 | 郝哥笔记 | 赣东北都市网 | 非学派 | 汇维网 | qactuz | 曹晨博客 | 笑天博客 | 电力队 | 生菜小程序 | 浅时光博客 | 主机吧 | 新手站长网 | 奇它博客 | 逐梦资源社 | 维链网 | 阳光实验室 | cqh | 西部盒子博客 | 爱极客 | 墨鸢の树洞 | 墨涩网 | idea激活码网 | 哈米酷 | 起点源码 | 淡看江湖路 | 杍杋源码

赞助支持

基础设施的建设需要大量投入,而又难有盈利模式,如果你也希望支持我的工作,请花一点时间看一下赞助政策^_^

  1. 我无法为赞助者提供任何形式的承诺或回报,换句话说:把赞助理解成捐赠比较恰当
  2. 目前资源类赞助(服务器、CDN等)由固定厂家供给,故只接受资金赞助
  3. 资金赞助分为周期性赞助和一次性赞助(支持者),其中周期性赞助分三个档次:金牌(3000+/月)、银牌(1000+/月)、铜牌(500+/月)
  4. 周期性赞助者终止赞助后,我会汇总已赞助的总金额,并归类到“支持者”中
  5. 资源类赞助者和金牌赞助者会获得全站LOGO展示权利
  6. 如果你决定赞助,请联系QQ:1642491905,非常感谢你的支持^_^

服务器赞助

CDN+云存储赞助

服务器管理面板赞助

金牌赞助

银牌赞助

铜牌赞助

虚位以待

支持者

574 评论

    • 孙锡源

      3.0.0版本已发布,支持了为官方仓库追加全量汉化支持,欢迎克隆github上的master分支参与测试^_^

      回复
    • 孙锡源

      忘了交代,发布的Beta版本,不是正式版。如果正式版发布你们会在WP后台收到更新推送的

      回复
  1. 豫章小站

    是你开发的吗,https://blog.mydns.vip/2715.html 绑定

    回复
  2. 硬币说

    看完文章看评论,感觉就是——
    牛……批……啊!!
    膜拜大佬!

    回复
    • 孙锡源

      不敢当呀,不过正在向成为大佬的方向上努力着

      回复
  3. NBD

    老问题
    Premium Addons for Elementor更新无效。

    回复
    • 孙锡源

      新上线的更新监控服务有一处BUG导致服务中断了,目前精力有限还没开发完整的服务可用性监控。已经恢复运行了

      回复
  4. ygdm123

    还有一个问题,使用elementor插件的时候选择模板会显示连接不到库的错误,经排查发现关闭wp-china-yes可以解决问题

    回复
    • 孙锡源

      加一下我QQ:1642491905,我远程给你看一下

      回复
      • ygdm123

        好像又好了 懵逼 再出现这个问题的话 我再留言

        回复
  5. ygdm123

    安装插件后打开搜索主题会出现下面的错误
    发生了预料之外的错误。WordPress.org或是此服务器的配置可能出了一些问题。如果您持续遇到困难,请试试支持论坛。

    回复
  6. NBD

    Elementor Pro无法更新,显示如下
    正在升级Elementor Pro专业版插件(1/1)
    正在从http://my.elementor.com/edd-sl/package_download/MTU5Mzg2MzU1Mjo4OTRjNjNhM2UzYzU4ZTY4ZWEyOGZjZTRlY2RjMTI0MzoxOmRiN2Y2YjE5MzBmYWEyZDUwODQ0ZDRiOGFmOTY0YTYwOmh0dHBzQC8vMDI3eWFuZmFuZy5jb206MA==下载更新…
    在更新Elementor Pro专业版时发生了错误:下载失败。 Forbidden

    从提示看,这个更新是从elementor官方的源下载的。这种问题似乎有点难解决

    回复
    • 孙锡源

      国区商城上线后会解决,大概要年底了。现阶段就是先把官方仓库已有的伺候舒服了

      回复
  7. E

    草?我赶上个大项目?
    WP-China-Yes插件是真的好用,博主加油!支持你!
    等我有空了也写篇推荐~

    回复
  8. NBD

    刚刚发现HubSpot All-In-One Marketing – Forms, Popups, Live Chat 无法更新

    回复
    • NBD

      elementor pro也无法更新

      回复
      • 孙锡源

        付费版插件走的是elementor官方的更新服务器,这个服务器未被WP-China-Yes托管。等国区商城上架后会对这些付费应用统一接管并提供汉化支持,不过要等至少年底了

        回复
      • NBD

        WPCopyRights(网站防复制插件)
        此插件无法更新
        古腾堡编辑器最新翻译同样无法更新。
        提示更新完成,但还是会出现在待更新列表中

        回复
        • 孙锡源

          翻译无法更新是一个BUG,已经修复了。WPCopyRights插件已经加入到更新监控列表中了。感谢反馈!

          回复
        • NBD

          WPcopyright到目前(2020年6月29日21:34:50)仍然更新无效。
          BBPRESS翻译更新无效。

          回复
          • 孙锡源

            尴尬,上次没测试,这次测试过是好了的,你再试一下。翻译那个出问题的原因是wordpress.org可以在插件版本不变的情况下推送新的翻译,这就导致会命中CDN缓存。我上次已经配置了不缓存规则了,不清楚为何没生效,这块还需要再观察下,我现在又手工刷新了一次。

          • NBD

            QQWorld Speed for China
            更新无效

            强烈呼吁弄个更新无效的便捷反馈渠道。

          • 孙锡源

            我明天把更新监控程序重写,让他能自动发现并监控所有无Tag包,无需再人工添加监控列表了。感谢你这几天把我拖延症治好了

          • 孙锡源

            新的解决方案已经部署,以后都不会再碰到这类问题了。翻译文件的更新还需要再观察下

    • 孙锡源

      HubSpot All-In-One Marketing – Forms, Popups, Live Chat 这个插件我在WordPress官方仓库貌似没搜到。你把插件安装目录的名称复制发我下,注意是目录名,别复制错了。比如说WP-China-Yes的默认安装目录名是wp-china-yes

      回复
  9. NBD

    似乎有个bug
    描述:
    列表里有N个待更新插件,点更新,WordPress提示更新全部完成,左上角的更新图标也显示没有待更新的了。
    但是一点“更新”,仍然有几个插件需要更新。也就是刚才虽然提示更新成功了,但实际上没有更新。

    不是每一个插件都如此,目前没发现那些不能更新的插件的共同特点。

    另外,好想找一款可以批量插入文章和页面的表单插件,但提交表单需要手机接收验证码(为了收集访客信息便于转化)。如果带有计算功能就更好了。
    哪位大哥知道这样的插件吗?

    回复
    • 孙锡源

      你把那几个插件的名单发一下吧,我手工加到更新监控名单里。问题是由于这些插件没打版本tag导致的。这个问题现在已经有比较好的解决方案了,会在未来上线。

      回复
      • NBD

        目前发现(但不限于)
        Elementor Addon Elements
        Social Icons Widgets & Block by WPZOOM
        WP Google Maps
        WPJAM BASIC

        回复
        • 孙锡源

          你反馈的这些已经可以更新了,WPJAM BASIC这个插件应该是一直都可以更新的,你再确认一下嘛,我试过是可以的。

          回复
          • NBD

            不是不可以更新,而是更新后提示更新已经完成,可是点“更新”后,这些插件还是待更新状态。也就是说更新无效。

          • 孙锡源

            我知道你的意思,这些已经可以更新了,你再试一下。你反馈的WPJAM BASIC这个插件应该是一直都可以更新的,你再确认下嘛。

          • NBD

            只能等下次了。因为我已经手动升级WPJAM BASIC了。
            目前WP GOOGLE MAP还是不能升级

          • 孙锡源

            你是不是选择的“备原”?主源已经没你反馈的这个问题了的。我刚刚测试的

          • NBD

            刚刚试了一下,WP GOOGLE MAP也可以成功升级了。

            哦也!

          • NBD

            是主源不是备源

          • 孙锡源

            话说,你没填邮箱,是怎么知道我回你消息了的?

          • NBD

            你咋知道我没填邮箱呢?
            🙂

          • 孙锡源

            我每次回复你,WordPress会给你发邮件,然后发不过去就会有退信,我现在邮箱里躺了好几封退信了。这样知道的

          • NBD

            其实原理很简单,就是人肉轮询。
            🙂

          • 孙锡源

            真难为你了……

  10. chaofeng chen

    安装完体验了一下,感觉是真的强!感谢。

    回复
  11. 胡不过

    博主的规划很宏大!对插件写了一篇推荐:https://jiqianhanre.com/jian-wangzhan/wordpress-maintenance-mode-fix.html

    回复
    • 孙锡源

      感谢推荐,是有你们的支持,这个项目才有了未来

      回复
    • 孙锡源

      是的,我也是这样认为的。这个世界就是被无数个星星之火一次又一次改变的

      回复
  12. Mins

    谢谢作者提供这么好的插件,完美解决博客国内更新问题

    回复
  13. 最省事聚集地

    WordPress自动化翻译系统太牛了,刚才把一个插件上传翻译后,结果很满意

    回复
  14. WPONE

    Wppao Sitemap和Data Tables Generator by Supsystic麻烦加入名单

    回复
  15. go破解

    已推广:https://www.gopojie.com/1101.html
    但是现在插件中心已经找不到了。

    回复
    • 孙锡源

      在github下载吧,被官方下架了,官方不允许插件通过第三方安装wordpress核心。
      不过下架不会影响更新推送的,你只要安装一次后面可以一直更新。

      回复
  16. yangxiao6

    站点名称改为:云轩阁
    文章链接:https://www.520yxl.cn/post-263.html

    回复
  17. 最省事聚集地

    真心实意再次邀请博主成为鄙站驻场博主,最闪亮的那位

    回复
    • 孙锡源

      不好意思,最近一直在忙自动化翻译和国区仓库整合的开发工作,没来得及打理博客评论。
      不过,关于驻场博主这个,我实在是才疏学浅,而且不善于写文章……不能但此重任啊~

      回复
      • 小刘

        推荐地址已修改为:https://gravatar.cn/archives/24146,感谢

        回复
  18. 最省事聚集地

    由于站点改版,请把原来的《喔最省事》改为《最省事聚集地》,推广链接改为https://www.ozss.com/151/,谢谢!

    回复
    • 孙锡源

      改好了已经,话说换了固定链接格式的话,为啥没把老的带html的格式跳转到新的上?

      回复
  19. 何昌全博客

    何昌全博客,已经分享,https://www.hechangquan.com/how/890.html

    回复
    • 孙锡源

      WordPress自动化翻译系统上线了,欢迎参与公测哦~

      回复
  20. 龙萱坤诺

    已推广
    地址:http://shequ.loncons.com/98745.html
    同时将该插件作为本站wordpress专题推荐插件。
    地址:http://shequ.loncons.com/systemsourcecode/wordpress
    聊表心意,支持作者,加油!

    回复
    • 孙锡源

      WordPress自动化翻译系统上线了,欢迎参与公测哦~

      回复
  21. kevin

    感谢作者,我前几天用还行,今天重新安装wp以后,就不行了,如果启动wp-china-yes,添加插件或主题时就提示“发生了预料之外的错误。WordPress.org或是此服务器的配置可能出了一些问题。如果您持续遇到困难,请试试支持论坛。”,网上没有找到同样问题的,所以来麻烦一下作者给提示下解决方法。

    回复
    • 孙锡源

      请在服务器上ping一下api.w.org.ibadboy.net。如果出现异常情况的话记得反馈给我哈!通常情况下都是服务器的DNS配置的有问题导致的,我之前看到过有老哥配置的1.1.1.1的DNS,这种在国内压根用不了的

      回复
      • kevin

        我放在了阿里云的虚拟空间上,可能是阿里云或者我域名解析时的问题,我再去试试看,by the way,有没有技术交流的群可以加一下

        回复
      • kevin

        我发现了问题,是因为我原来使用的是共享虚拟主机,我今天改成独享虚拟主机就ok了,谢谢你的插件

        回复
        • 孙锡源

          万网的共享主机用的技术很老了……之前也有用户反映过这个问题,可能是他的openssl组件版本太老导致的

          回复
  22. 秋水

    莲梦青语博客已推广https://lmqyu.cn/1504.html

    回复
  23. zkl2333

    哈哈,看你玩的那么开心,我也该考虑typecho换回wp了。感谢WP-China-Yes,我先装个wp试试水。

    回复
    • 孙锡源

      其实建站的话,第一选择就是WordPress了,可以享受开源社区这十多年的生态积累,有兴趣可以来群里交流嘛

      回复
  24. 咸寒少

    Jetbrains免费全家桶?我喜欢给我整一份嘿嘿!

    回复
    • 孙锡源

      Jetbrains家规定是只给核心开发者提供,我申请试试嘛

      回复
  25. nwell

    请问php版本一定要7.2以上吗?

    我在本地wamp环境运行想安装,提示php版本过低(wamp的php是7.0.4)

    回复
    • 孙锡源

      最低要求应该是5.6不应该是7.2的,如果一直报错的话可以尝试把插件包头部的注释中的PHP版本号去除。

      回复

提交评论

邮箱地址不会被公开。 必填项已用*标注